align principal axis for MD

Discussions on how to set up simulations, typically starting from a pdb file.
Post Reply
sitiazma
Posts: 11
Joined: Tue Sep 15, 2009 12:29 pm

align principal axis for MD

Post by sitiazma » Fri Sep 18, 2009 10:59 am

Hi all,

Does it possible to set align principal axis for MD?

There is the align principal axis in test jobs for the hippo_input.txt but only for MC. In the manual.pdf, this setting does not say whether it is only for MC. I got the error msg as below when tried to use it with MD:

from the log.txt
Error: unknown input command:
align principal axis (-1 = flip pi) 3

thank you for you help
Last edited by sitiazma on Fri Sep 18, 2009 11:55 am, edited 1 time in total.

martin
Developer
Posts: 38
Joined: Sun Jun 15, 2008 10:27 pm

Re: align principal axis for MD

Post by martin » Fri Sep 18, 2009 11:50 am

Hi,

Yes, the align principle axis works always, 0,1,2,3 are off, x,y,z axes +/- does orientation (i think). You can also set it to align to backbone atoms only. Check the log.txt file for a complete input file, you can take the options from there.
Let me know if this helps!
Best wishes,
Martin

sitiazma
Posts: 11
Joined: Tue Sep 15, 2009 12:29 pm

Re: align principal axis for MD

Post by sitiazma » Fri Sep 18, 2009 12:06 pm

Thank you for your quick reply.

As my previous mgs, I pasted the error msg from the log.txt.

I have tried this paramater of align principal axis in MC, yes it's working. From the movie we will see the movement of the helix. I added this parameter line in MD input file, but the log file gave me the error msg.

I am testing single transmembrane helix, therefore I want to make sure it will align to z-axis of the membrane as we do in explicit bilayer. How actually to make sure the transmembrane domain to align to the bilayer normal and at the same time positioned at the center as we do in explicit bilayer?

martin
Developer
Posts: 38
Joined: Sun Jun 15, 2008 10:27 pm

Re: align principal axis for MD

Post by martin » Fri Sep 18, 2009 2:05 pm

Hi,

Can you send me your input file? I'll have a look, you can attach it to your reply.
Sorry you're having trouble.
Best wishes,
Martin

sitiazma
Posts: 11
Joined: Tue Sep 15, 2009 12:29 pm

Re: align principal axis for MD

Post by sitiazma » Mon Sep 21, 2009 8:57 am

Hi Martin

Actually, I only making the test by using the files from the test jobs. I changed the vpu_GBIM input file with the walp_MD input file. In addition with one line of the align principal axis.

Below attached is the hippo_input.txt

Thank you.
Attachments
hippo.tar
(610 Bytes) Downloaded 348 times

martin
Developer
Posts: 38
Joined: Sun Jun 15, 2008 10:27 pm

Re: align principal axis for MD

Post by martin » Mon Sep 21, 2009 2:12 pm

Hi,

I can't open your file, sorry. Can you upload again renaming the file ending to .dat. I'll fix the forum so one can upload .txt files asap. Sorry for the inconvenience!
Best wishes,
Martin

sitiazma
Posts: 11
Joined: Tue Sep 15, 2009 12:29 pm

Re: align principal axis for MD

Post by sitiazma » Thu Sep 24, 2009 11:17 am

Hi,

Regarding the "align principal axis", I 've made some testing for x, y and z axis. The results are: when the input is 2/-2 (y) or 1/+1 (x), the helices will align to normal axis (z-axis). But, when with the input 3/-3, the helices will align to other way, maybe x or y. Thus, for my case, which I want my helices to align according to bilayer normal, so I need to give input 1/-1 or 2/-2. Hope I am doing this correctly.

Best regards

martin
Developer
Posts: 38
Joined: Sun Jun 15, 2008 10:27 pm

Re: align principal axis for MD

Post by martin » Thu Oct 01, 2009 4:23 pm

Hi,

the bilayer normal is the z-axis, this should be the alignment axis for your peptide if you want to have the system trans-membrane inserted. The membrane is centered on z=0. Hope this helps.
Best wishes,
Martin

Post Reply