Novice assistance

Please report bugs and crashes. Read the first post about reporting bugs, please. Depending on volume we may later switch to a dedicated bug tracking system.
Post Reply
denniej0
Posts: 6
Joined: Tue Jul 01, 2008 11:11 pm

Novice assistance

Post by denniej0 » Mon Oct 06, 2008 9:17 pm

This is probably a stupid problem so please bear with me as I'm a novice when it comes to Hippo.

I downloaded both the Windows and Linux version of Hippo and am having difficulty running the executable file. I get the same error for both versions "Illegal instruction". I'm not sure what this means.

I think I've followed the manual correctly (but perhaps not as this is my first time using Hippo). I've run the following:
./hippo hippo_input.txt

The error I get is "Illegal instruction". The text file (hippo_input.txt) is simple:
mode: MD simulation
input type: PDB
input file: helix.pdb
max_mcsteps: 1000

I even tried:
./hippo
with the thought that if it worked that it would just hang regardless of the command options afterward. I still get the same error mentioned above.

Am I doing something wrong or could it be that the executable is looking for library paths that don't exist or are different on my computer?

If it helps I'm using an old Redhat linux computer (with a 2.6.9-22.ELsmp kernel).

Many thanks in advance for your help!

jakob
Developer
Posts: 6
Joined: Sun Jul 06, 2008 4:54 pm

Re: Novice assistance

Post by jakob » Wed Oct 08, 2008 9:38 am

Hi,

the 'illegal instruction' immediately after starting both on linux and windows looks like a similar 'bug' I wasted a whole day on.
hippo is compiled to use SSE2 instruction set for speeding up double precision. Please check your CPU. If it is an Athlon XP you will have problems, because it only supports SSE1. All Intel CPUS from P4 on have SSE2.

You can check your cpu by downloading CPU-Z for windows. I forgot how to check it in linux.

If this is the case, then I can easily compile you a version that does not use the SSE2 instruction set, it is just a compiler flag.

I will look whether I can use a comiler flag that immediatly stops the program with 'architecture not supported' in case the CPU does not support the instruction set.

best wishes,
Jakob

martin
Developer
Posts: 38
Joined: Sun Jun 15, 2008 10:27 pm

Re: Novice assistance

Post by martin » Wed Oct 08, 2008 9:53 am

Did you just put the three lines you quote in your post as input? Hippo needs the whole hippo_input.txt file with all the commands at the exact row and column as in the original file. If you want to change an option simply replace the corresponding command/number with yours. If you omit lines or move the column of the commands it will crash. We should probably change that... ;)

denniej0
Posts: 6
Joined: Tue Jul 01, 2008 11:11 pm

Re: Novice assistance

Post by denniej0 » Wed Oct 08, 2008 2:00 pm

I used the standard input file that came with the program first but I still got the same error. When that happened I decided to take a minimalist approach and put only a few commands in the script. It's good to know that in the future I can't do that. The CPU's that I'm working with are:

vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 6
cpu MHz : 932.091
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips : 1859.58

So they're intel but really old intel and no SSE2 flags are listed just SSE.

denniej0
Posts: 6
Joined: Tue Jul 01, 2008 11:11 pm

Re: Novice assistance

Post by denniej0 » Thu Oct 09, 2008 5:05 am

Many thanks Martin and Jakob.

The issue was definitely the CPU and CPU flags. I installed a new CPU with SSE2 on the Linux computer and now executing hippo is no longer an issue!

Many thanks again!

jakob
Developer
Posts: 6
Joined: Sun Jul 06, 2008 4:54 pm

Re: Novice assistance

Post by jakob » Tue Oct 14, 2008 5:37 pm

There is a new version of hippo, which also provides executables for older computers

Please get it at www.biowerkzeug.com

enjoy, Jakob

oliver
Site Admin
Posts: 18
Joined: Fri Jun 27, 2008 8:18 pm
Location: Oxford, UK
Contact:

Re: Novice assistance

Post by oliver » Sat Oct 18, 2008 6:13 pm

Thanks, the new binaries (revision 26) work well (tested on Linux).

The hippo and hippo_mpi binaries work on modern dual cores (with SSSE3) whereas the hippo_p3 and hippo_p3_mpi one work on older processors.

If in doubt, just try them out in order and take the first one that works.

I also put notes on the wiki about Installing Hippo which mentions this.

Post Reply